2.5.1 -> 3.0

With the update from v2.5.1 to v3.0, ARway has reworked the entire structure of the SDK to enable us to update the ARway app alongside the SDK. This way, updates to the SDK will be performed more frequently.

For this update, your ARway project will need to be rebuilt from the source code for access to the new features.

Instructions on how to build from the source code can be found from the following link:

pageBuilding from the Source Code

If you have integrated the ARwayKit .unitypackage with your own app, you can follow these steps to remove the old version and integrate the new one.

Replacing ARwayKit in an existing Unity Project.

This guide will walk you through the process of upgrading v2.5.1 of the ARwayKit SDK to v3.0.

  1. Backup Your Project: Save your Unity project with your version control system (such as Git) to ensure you can revert in case of any unforeseen issues.

  2. Delete the ARwayKitSDK Folder: To remove the package, delete its folder from the "Assets" directory. Right-click on the folder "ARwayKitSDK" and select "Delete".

  3. Remove References: After deleting the folder, you may need to clean up any references to the package in your project, such as script references or references in your scenes. Unity might display errors in the Console window indicating missing assets, so you should address and remove those references as well.

  4. Add the latest ARwayKit .unitypackage: Integrate the latest .unitypackage by following these steps: Integrating the Unity Package

  5. Build and Test: Rebuild your Unity project and thoroughly test all the ARway features and functionalities that your application uses.

Last updated